The earlier issue causing delays in document signing and email branding has been resolved. The disruption was due to an outage in Microsoft Azure services, which has now been fully mitigated by Microsoft.
All BoldSign services are now operating normally. We’ll continue to monitor system performance to ensure stability.
Thank you for your patience and understanding.
Posted Oct 29, 2025 - 18:02 EDT
Identified
We are currently experiencing delays in document signing and temporary issues with email branding due to an ongoing Azure service disruption. Our team is actively working with Microsoft to restore normal operations as soon as possible. Thank you for your patience and understanding.
We are currently investigating an issue affecting document signing and email delivery. Some users may experience delays or missing branding in emails. Our team is looking into the cause and will provide an update soon.
Posted Oct 29, 2025 - 12:30 EDT
This incident affected: Web App (Web App (Global), Web App (Europe), Web App (Canada), Web App (Australia)) and API (API (Global), API (Europe), API (Canada), API (Australia)).