A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 16:20 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 15:00 EDT
Investigating
We are currently experiencing a partial service disruption due to an ongoing outage in one of the Google Cloud data centers that our service relies on. While the service continues to work for some customers, others may face intermittent issues.
We’re actively monitoring the situation and will fully restore our services as soon as Google resolves the outage.
Posted Jun 12, 2025 - 14:00 EDT
This incident affected: Web App (Web App (Global), Web App (Europe)) and API (API (Global), API (Europe)).