Temporary Delay in Email Delivery

Incident Report for BoldSign

Resolved

We’re happy to inform you that the temporary email delivery impact affecting BoldSign has been fully resolved.

We appreciate your patience and understanding during this time. If you have any further questions or concerns, please don’t hesitate to reach out to our support team.
Posted Feb 07, 2025 - 05:31 EST

Monitoring

We're pleased to inform you that the issue with delayed email delivery has been resolved. New emails will now be delivered without delay, and any previously delayed emails will be sent out shortly. We appreciate your patience and understanding throughout this process. If you have any further questions or concerns, please feel free to reach out to our support team.
Posted Feb 07, 2025 - 03:48 EST

Investigating

We are currently experiencing delayed email delivery for signature requests. Our team is actively working to resolve these issues as quickly as possible, and we will keep you updated on our progress. We sincerely appreciate your patience and understanding. If you have any urgent concerns, please don’t hesitate to reach out to our support team.
Posted Feb 07, 2025 - 02:58 EST
This incident affected: Web App (Web App (Global)) and API (API (Global)).