Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 25, 2024 - 23:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 25, 2024 - 05:41 EDT
Scheduled
We will be performing scheduled maintenance and upgrades to improve your experience on the BoldSign on October 26th from 5:00 a.m. to 6:00 a.m. CET.
Please note that all BoldSign services will be temporarily unavailable in the European region during this time. Rest assured, your documents will remain safe and secure.
Thank you for your patience and understanding as we work to enhance our platform.
Posted Oct 25, 2024 - 03:37 EDT
This scheduled maintenance affected: Web App (Web App (Europe)) and API (API (Europe)).