Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 16, 2024 - 01:00 EST
Scheduled
We will be performing scheduled maintenance and upgrades to improve your experience with BoldSign on November 16th from 1:00 a.m. to 2:45 a.m. EST.
Please note that all BoldSign services, except those hosted in our European data center, will be temporarily unavailable during this time. Rest assured, your documents will remain safe and secure.
Thank you for your patience and understanding as we work to enhance our platform.
Posted Nov 15, 2024 - 05:52 EST
This scheduled maintenance affected: Web App (Web App (Global)) and API (API (Global)).